Failed to verify connection 'My Xero connection'. Status Code Error: 400

Hi all

From time to time I get this message “Failed to verify connection ‘My Xero connection’. Status Code Error: 400” and all my scenarios start to fail. And of course this often happens whilst i am on holiday!

So a couple of questions - why does it keep happening and what can i do about it?

when i go to try and verify or reauthorise i get this:

many thanks



I’m also getting this very regularly. Like - daily.

It’s becoming an extreme disruption - I have a lot of Xero integrations and they all break at once, meaning I wake up and check my email to dozens of errors.

I ‘Reauthorize’ and then all works well again… until it doesn’t.

1 Like

Going to add to this!

HUGE annoyance for me. Happening multiple times a day!


Adding this same.
Same error for our end
We already rebuilt our connections and scenarios last month and was told that this issue should no longer happen

Failed to verify connection ‘My Xero connection’. Status Code Error: 400

1 Like

Also regularly seeing this issue

1 Like

I did reach out to Make support, but eventually they sent me to Xero - who of course said it wasn’t their problem as there is no issue with other platforms. And that I should talk to Make support!

It is comforting though that i haven’t been singled out in the universe to have this problem :grinning:


1 Like

Make Support have just come back to me with some good news:

"This issue was already been reported to our development team after further investigation, we have come to the conclusion that this is indeed an issue on our end.

We are actively engaged in addressing this matter and will ensure to provide you with a timely update once we have made significant progress. Your patience and understanding are greatly valued."

So hopefully soon there may be a solution!


Hi, has there been any update on this? Mine has just started having this issue as well. Very frustrating!

Also having this issue daily but thought it was my fault as I only started using a month ago!

We’ve noted that when searching for “Xero 400 error” in search engines, there’s quite a few reports of Xero users getting the following error in the Xero web UI:

HTTP Error 400.The size of the request headers is too long.

Has anyone who’s been experiencing the problem with Xero and Make also getting this error in the Xero web UI?


Hi Dave,

i don’t get an error message in Xero - only in the scenario - and it doesn’t mention headers there just:


Failed to verify connection ‘My Xero connection’. Status Code Error: 400



1 Like

#I don’t know if this will help Dave, but as it happened again this morning, and my inbox had many emails from make with the same error, i went to connections and tried to VERIFY, but i get this:

This may give a clue? I dont know if others get this?

Reauthorising seems the only way to make my scanrios all work again.



This has been a nuisance for ages, it’s just got worse recently, now happening every day or more than once a day rather than once every few weeks. Would be so good to get it fixed!

Dave - I don’t recall ever seeing that in the Xero UI.

I have to hit the Xero API more than once in each workflow. I have 2 workflows talking to Xero, and I think no way to make sure they don’t run simultaneously. I wondered whether there was some rate limit problem.

But the first error to appear is an error 400, I don’t know if Xero returns more useful info than gets to us in the Make UI?

1 Like

Going to have to look at other platforms.

Make cannot even provide an ETA.


Having this issue as well - started on Friday, and still not working today.

I’m running about a dozen automations, across 2 Xero accounts and interestingly, only one of them seems to be affected by this bug. The rest are still running fine.

This happened once before, about a month ago. Again, only affected one of my two connections. Had to manually reconnect Xero account on all the broken automations and restart them. Don’t want to have to keep doing this once a month or more.

1 Like

Guys this is getting ridiculous! This issue isn’t isolated to Xero! I have my own app on the Xero app store and I don’t run into issues like this.

My clients on Make alot of them who use Xero are starting to get quite frustrated as they are having to reauthorize almost at least once every week now!

Please look into a fix urgently

1 Like

Getting this on a daily basis. @MAKE_USER_2 please fix

  • Failed to verify connection 'My Xero connection'. Status Code Error: 400
  • Failed to verify connection 'My Xero connection'. Status Code Error: 400
  • Cannot initialize the scenario because of the reason 'Failed to verify connection 'My Xero connection'. Status Code Error: 400'
1 Like

We also are getting this several times a day across multiple organisations with different xero connections. If we cannot find a solution @MAKE_USER_2, we will be forced to look elsewhere as this is almost more laboursome than the the automated process is to undertake manually.

1 Like

completely agree with Billy_blake’s comment.
This is a complete pain , multiple times a day. how has this not been fixed!

Message from the Make Support Team

"please be assured that we are fully aware of the situation, and our development team is actively involved in pinpointing the underlying cause. They are diligently working on implementing a permanent solution to resolve this issue. "

So bear with them!

1 Like