Failed to verify connection 'My Xero connection'. Status Code Error: 400

Hello everybody @here

There’s been a very understandable amount of concern among Make/Xero users on this issue. While we’ve been working hard on identifying and resolving the problem, we could have done a better job of communicating with you all on this. For that, we’re truly sorry.

We recognize that Xero is an important system of record for many users and that the smooth running of workflows involving Xero is often of vital importance. The level of concern shown on this Community (and in reports to our Support team) reflects that.

Our core engineering team has been working hard on this since it was first reported just over a month ago and our senior management is aware of this issue and its impact. We’ve assigned resources specifically to reproduce, investigate, and fix the problem.

What’s made this problem harder to resolve is it has proved extremely difficult to reproduce it reliably:

  • Not every Make user with the Xero app in a live scenario is experiencing the problem (we believe that it’s affecting around 10% of Xero users in Make).
  • Where it does occur, it’s not affecting every scenario.
  • When it does occur in a scenario, it’s not on every run.

We have now been able to create a scenario that is guaranteed to exhibit the problem on a daily basis and are expecting progress soon.

We are very sorry for all the trouble this has caused you all and we’ll aim to give regular updates on this issue as we work to conclude it.

Thank you very much for bearing with us :pray:


Not sure if this is of help, the issue only seems to happen on Make. I am in the process of migrating and have some scenarios on Integromat and some on Make and only the Make ones show this error.


Thanks @Michaela - it’s really good to know what’s going on.

I note you say that it was first reported just over a month ago. I think very similar symptoms have been reported before that, but not accepted as a problem with the Make platform. I’ve been having similar problems for much longer, just at lower frequency. I really hope once you’ve fixed this that we don’t just go back to having to re-auth Xero every week or two.


@michaela , i think it has to do with the # of requests in a short time period.

I have split up my scenario which has probably 50 xero API nodes like this:

  • Two connections split randomly amongst the xero nodes
  • added ‘sleep timers’ between the connections to slow down the whole scenario.
  • reduced schedule run from 5 minutes to 15 minutes

Have not had to log in for 72 hours which is the best it has been in the past month+

1 Like

Thanks a lot for the updates, everyone :pray: I passed all the info to the dev team.

As soon as I learn any news on this matter, I will make sure to update you all.

Hi team, any update on this? Only so long we’re able to sustain the way it is before using another platform (really don’t want to).

1 Like

Hello everybody @here :wave:

Slight update from our end: the team has found the root cause of the problem and a fix is getting ready to be delivered as soon as possible.

Once again, I apologize for the trouble this has been causing you. Thank you very much for your patience and your understanding :pray:

I will keep updating you here as soon as I learn anything new.

1 Like

Very possibly!

As a separate problem - although possibly related, I also noticed that Xero will crap out when there are too many API calls (This is a fact - not a theory; I remember reading the docs and/or seeing it in the error message)

In order to solve that problem, I ended up having a Break error handler on any Xero call on all of my scenarios, and have it retry a minute later. I was working on a bunch of inter-connected scenarios that called each other via webhooks that had a lot of Xero calls. When I eventually ran it to back-run through an entire year’s worth of Shopify orders, I ended up probably having thousands of Xero calls. The break handler solved that perfectly - it definitely had failed scenarios, but it just retried.


Can anyone on the instances that received the fix confirm that it has worked? On tenterhooks over here on eu1.

Hello everyone @here

I just wanted to let you know that the fix has been deployed across all our production zones. We’re expecting everything to run smoothly from now on.

If you happen to encounter any lingering issues with your authentication, please don’t hesitate to reach out and let us know.

Once again, I would like to apologize for the headaches this has caused you all. I understand this must have been frustrating.

Thank you very much for your understanding and for bearing with us. :make: :pray:


Thank you! Fingers crossed things are nice and stable from here on out!

Still no success for mine. It’s failed twice since Michaela’s post - Failed to verify connection 'My Xero connection'. Status Code Error: 400, the automation is stopped and I’ve had to manually reconnect.

Its a scenario that runs every 2 mins so it works lots of times and then randomly stops.

SO frustrating as this automation links our CRM, our project management system and our finance system…

I’m still getting Xero errors:


Retrying a few minutes later and it works without reauthenticating.

Hello @Andrew_B @ttt :wave:

I am very sorry to hear that you’re still experiencing these issues.

Could you please verify whether these problems persist even after you reauthorize your connection? It appears that the applied fix might not work seamlessly in all cases since it needs a freshly generated token pair.

Reauthorizing the connection should typically resolve the issue. However, if it doesn’t, creating an entirely new connection should ensure that there’s no “old data” associated with it, and fully utilize the updated code.

If the above-mentioned steps do not solve the issue, please reach out to our support team and they will be happy to assist you with getting this up and running.

Hi Michaela,

I will try reauthorising. I’m assuming creating a new connection would mean updating the Xero module in every scenario it is used in? This would be very time consuming!

Still encountering the same issues after the fix. Support says they’re aware and are working on it again.

Hello everybody @here

Unfortunately, our dev team had to reopen this issue and is working on fixing it. I’ll post an update here as soon as I learn anything new.

I am truly sorry to be the bearer of the bad news and I want to express my apologies for the frustration and inconvenience this situation has caused.

Your patience and understanding are greatly valued. :pray:


I would be interested to know if others having the issue are accessing Xero simultaneously from multiple Make scenarios.

I’m wondering if scenario 1 creates a connection to Xero.
Scenario 2 then creates a new connection.
If scenario 1 then reaches another Xero module if that fails as the connection has been changed?
Does this sound plausible?

came here to post i’m still having issues as well!

1 Like

Im using one scenario only - just got error today again