Google Sheets Search Rows Returning No Data with 'AND' Filters

I have a webhook as trigger, and the webhook provides input data, see below:

The first action is to search a google sheet for those exact data using the text equal to filter, see below:

There is the exact data in the google sheet, but I am still getting no output.
My next step would be to create a new row in a new google sheet, but since there is no output, no new row is being added.
I have seen other topics where this issue has been solved by removing the filters, but I NEED THE FILTERS.

This seems like a complex scenario you’re trying to make, perhaps exporting the blueprint might help others investigate further and answer your question.

At the bottom of the scenario editor, you can click on the three dots to find the Export Blueprint menu item.


Uploading it here will look like this:

blueprint.json (119.3 KB)

Also, it would be helpful if you can provide a sample spreadsheet with the rows you are trying to search for.


Hey, thanks for your answer.

Below is the blueprint:
Webhook to Search GS to Add Row GS.json (32.5 KB)

Here’s a screenshot of the sheet:

I’m surprised that this is deemed to be complex as it seem pretty simple and straightforward to me.

As you can see, the webhook data is: residential, moka, 25000000.
There is this same data on row 5.
I then simply wanted to output to be the whole row (row 5), added to a new blank GS.

Thank you.


Hi @Muktish_Narain

It appears that in the Google Sheet, the word “Residential” starts with a capital letter, while in the webhook, it is displayed as “residential” in lowercase

So I think you can make filter with {{startcase()}} option.

MSquare Support
Visit us here
Youtube Channel



You solved it man, I feel dumb, but thanks.

1 Like

Hi @Muktish_Narain

I am glad to know that my solution has assisted you in moving forward.

If you require additional assistance, please feel free to reach out.