How to get time date filter to work

Hi I’m trying to add a filter to a module so that bundles will only pass between certain dates and times eg between 10 June 2024 06:54 and 10 June 2024 18:54

The date I am matching from a previous module is ‘created timestamp’ in the format 2016-12-28T16:03:06.000Z
Screenshot 2024-06-11 at 10.26.53

My filter is as follows. I am aiming to parse the date added from the calendar to match the created timestamp:

I have got as far as the bundle passing the first of the filter tests, but don’t understand why it isn’t passing both, when it meets the requirements? (The bundle date is from my first image: 2024-06-10T14:52:43.000Z)

What have I got wrong here?

Your parseDate format is incorrect, and not matching the date string in the first parameter.

Here are some useful links and guides to help you get started and learn more on how to use the Make platform, apps, and app modules —


Help Center Basics

Articles & Videos

samliewrequest private consultation

Join the unofficial Make Discord server to chat with us!

1 Like

I have only posted here because I have spent a long time reading the guidance and trying many options, but still got stuck. I was hoping for a friendly reply to point me a little more specifically to my error, rather than a link back to the general guidance which I have spent a lot of time on. Unfortunately this hasn’t helped me find the solution, which is why I’ve come hoping for some friendly advice in the Community.

After looking again at the guidance, I have also tried the following that is still an error
{{parseDate(“10/06/2024 06:54”; “YYYY-MM-DDTHH:mm:ss.SSSZ”)}}

I would love to know the element that is wrong that isn’t matching the date string in the first parameter? I can’t see the mistake.

1 Like

You’ll need to parse the created timestamp variable into a date before you can compare it with another date.

According to the Tokens you can use to parse a date variable “Created Timestamp”, you can use D MMMM YYYY HH:mm.

e.g.: {{ parseDate(13.createdTimestamp; "D MMMM YYYY HH:mm") }}

For more information, see Date Formats in the Help Center.

Then, in the bottom, your date is using slashes / but your format is using hyphens -

samliewrequest private consultation

Join the Make Fans Discord server to chat with other makers!

1 Like

Thank you @samliew that really helped

I have now got to the solution here. This is based off formatting input date to match the format of the date from the inbuilt calendar (as in this screenshot)

To clarify what I had been doing wrong, for anyone who comes back to this

  • I was using parseDate instead of formatDate. The latter is needed as the original date was date format
  • I had got the formatting the wrong way round. What I needed to do was changed the original input data (format it) to match the date I was inputting via calendar (not the other way round).

I hope this helps others and thank you Sam again.


No problem, glad I could help!

1. If anyone has a new question in the future, please start a new thread. This makes it easier for others with the same problem to search for the answers to specific questions, and you are more likely to receive help since newer questions are monitored closely.

2. The Make Community guidelines encourages users to try to mark helpful replies as solutions to help keep the Community organized.

This marks the topic as solved, so that:

  • others can save time when catching up with the latest activity here, and
  • allows others to quickly jump to the solution if they come across the same problem

To do this, simply click the checkbox at the bottom of the post that answers your question:

3. Don’t forget to like and bookmark this topic so you can get back to it easily in future!

4. Do join the unofficial Make Discord server for live chat and video assistance

samliewrequest private consultation

Join the unofficial Make Discord server to chat with other makers!