Insufficient permissions to create new select option

I’ve had a scenario working for a while, but all of the sudden, I’m getting an error trying to create records.

The operation failed with an error. [422] Insufficient permissions to create new select option ““XFS778””

I am using the Create Record module. I have removed and recreated the module completely. I made sure that all fields in Airtable have the permissions of Editor and above.

Any suggestions?

Hi @Kuzanagi ,

There is a similar topic here, it may help you.

But it doesn’t explain why it was previously working for you.




this looks incorrectly double-quoted for some reason.

Welcome to the Make community!

1. Screenshots of module fields and filters

Please share screenshots of relevant module fields and filters in question? It would really help other community members to see what you’re looking at.

You can upload images here using the Upload icon in the text editor:

2. Scenario blueprint

Please export the scenario blueprint file to allow others to view the mappings and settings. At the bottom of the scenario editor, you can click on the three dots to find the Export Blueprint menu item.

(Note: Exporting your scenario will not include private information or keys to your connections)

Uploading it here will look like this:

blueprint.json (12.3 KB)

3. And most importantly, Output bundles

Please provide the output bundles of the modules by running the scenario, then click the white speech bubble on the top-right of each module, save the bundle contents in your text editor as a bundle.json file, and upload it here into this discussion thread.

Providing the output bundles will allow others to replicate what is going on in the scenario even if they do not use the external service.

Following these steps will allow others to assist you here. Thanks!


With the default Airtable modules it is not possible (anymore) to add new selection options for Single select and Multi select fields. This is to prevent your selection fields being populated with unwanted options.

This is due to the “Typecast” option and might be an issue when creating or updating options.

While we wait for the Airtable app to be updated (vote for this feature request) and get and advanced option to enable typecast, there are two workarounds:

  1. Rebuild your Airtable call using the “Make an API Call” module.
  2. Set the typecast option in the Make module code:
  • Copy the Airtable create/update/upsert module (right click > copy)
  • Paste in a text editor (any application that can edit plain text)
  • Search for the “typecast” option (usually somewhere in the first 20 lines)
  • Change “false” > “true”
  • Select all the code and Copy
  • Paste it back in your scenario to get a copy of the original module with typecast set to true.

I usually put this behind an error handler to do some extra checks before creating the extra option.

P.S. If you see this, please also vote for the option to be added to the Make Airtable app (link above).