Invalid URL in parameter 'url'. (When I post to facebook or reddit)

At first I thought it was because there was no https:// or www.

I’ve tried various combinations and included both, and just one of each, but it never works

If I however paste the link in manually (a static link)
It will post with success

But if I use the text content from gmail which has a link only and nothing else whatsoever, it will not let me post due to this error

the email contains the link only and nothing else
no spaces
no line breaks

I’m trying to build an automation, where if I share a youtube video link to a specific email address with a specific subject/label, it will post to to various places and other social medias, with a random title based on a column full of choices in google sheets

Hmm, try using trim function on text content and see if that fixes the issue.

1 Like

I solved this by wrapping the “Text Content” Atttibute with trim

trim(Text Content)

There may have been a return key or spare space somewhere

Hello @Ceeceefox99 :wave:

Brilliant that you got this to work and thanks for sharing what did the trick for you :clap:

Just so you know, I’m marking your last comment as a solution so that users who are looking to do something similar can easily find the answer :white_check_mark::slightly_smiling_face: