Make slow in general recently

Has anyone noticed the make in general has gotten very slow recently - all actions (loading pages, transitions after clicking something, saving scenarios even logging in etc)?

What im experiencing is not specific to any scenario (i know huge scenarios take time to save for instance), it could be a 2 module scenario or a 200 module scenario, everything seems just sluggish.

Welcome to the Make community!

You can view any slowdowns in the service on the official status page https://status.make.com/

For technical issues like this, directly contacting support can often lead to a faster resolution. They have access to your specific account details, scenario and scenario logs, server-side logs, and internal tools and resources, which allows them to investigate more thoroughly than what you have access to.

You can open a new ticket, or if you are unable to login for some reason, you also can reach support using the contact form on the website.

If you manage to get your issue resolved with support, we’d still love to hear about it! Sharing your solution on the forum can help others facing similar problems.

samliewrequest private consultation

Join the unofficial Make Discord server to chat with us!

2 Likes

Yeah totally. So slow and a lot of errors. Even Logging in takes a while.

First,I thought it was my browser problem. So I deleted browser installed again but haven’t changed a bit. I tried with other labtops but it was all same.

Need some change here!

Do you happen to be on the US1 server as well? It appears other US customers are also experiencing the same issue over the past day. Follow this later thread for updates: Huge outages

Join the unofficial Make Discord server to chat with other makers!

1 Like