New Airtable API Credential Types Announced - Migration Plans?

Airtable just announced that they’re switching their credential types for API access – with plans to deprecate the old credentials in about 1 year from now:

Can someone from the team comment as to when their Airtable modules will support these new credential types? And what the migration strategy might be to switch from the old credential type to the new credential types?


I tried plugging in a PAN token into the Airtable module, but it’s yielding a 403 error:


1 Like

@dkindlund picked it up and we will update you here.

As Airtable is one of our most used Apps, I am quite sure we will be ahead of time and make sure the transition is smooth.

1 Like

Our team is working on implementing a fix once the new API is released an official update will follow via the change logs. Please keep in mind Airtable is one of our top 10 apps. We got this covered!


Hey Sebastian - Can I want confirm the changelog you’re referring to is the one at the bottom of this page? No updates yet, looks like.

Hey there, are there any updates on when support for the API credential types will be added?

Hi @PLIX_Team welcome to the community :wave:

You can currently use Airtable with an OAuth or a Personal Access Token.

You can find more info about Airtable OAuth here: 🟣 Airtable OAuth Available on Make

I have a concern regarding the Airtable modules that currently rely on the outdated connection. Is it necessary to establish a new connection using oAuth and update the connection for each of the numerous Airtable modules in Make?

Hello @iAUnz :wave:

Yes, changing the connection would be the right thing to do. You can use our DevTool in order to make the process smoother.

Thanks Michaela,

The DevTool only seems to permit changing the connection within the scenario - is there a way to do it across all scenarios at the same time?

I see @iAUnz, my apologies for the confusion.

Unfortunately, this is not currently available. However, you could submit it as a feature request to our Idea Exchange, where our team can review and consider your suggestion.

@SebastianMertens and @Michaela , thanks for the heads up on this new feature. The documentation is a bit spare, though.

For the Proxy options in “Advanced”, I see just the “Sync Inc” option. Is that the same as ? Or is this using a different proxy provider? (I’m just trying to avoid naming confusions here.)


Lastly, are there any plans to allow users to specify their own 3rd party proxy domains?

To be crystal clear, it would be super helpful if the exact domain of the proxy service were exposed/visible in the drop-down, so that you can avoid user confusion.

For example, showing as an option.


@SebastianMertens and @Michaela , so this is a little frustrating. I’m creating a Personal Access Token (PAN) using an Airtable Service Account (available for Airtable Enterprise Customers).

I create the credentials within the Service Account interface here:

But when I try to use these credentials in the Airtable module, I get this 403 error:

^ Any idea why this isn’t working?

Okay, I think I see the problem. I needed to add this additional scope in order to get it to work:


If that scope isn’t specified, then the connection yields a 403 error.

I’d recommend you guys update your documentation to specify what the minimum scopes are needed for Airtable Enterprise Service Account PANs. FYI.


Hi @dkindlund thanks so much for taking to time to go into such detail here.

Great catch! Sync Inc has actually changed their name to Sequin. Thank you for bringing this to our attention. I’ll make sure to pass this information along to our documentation team so that they can update our help docs accordingly.

You’re absolutely right about that. Thanks for flagging it and bringing it to our attention. I’ll make sure to pass this on to the team so they can update this with the correct information.

Thank you so much for taking the time to point this out and help us improve our resources.

This is currently not planned but you can log it as a feature request in our Idea Exchange space.

Hope this helps!

Thank you for mentioning this. I was having the same issue! Adding that scope fixed it!