Only 1 database appears in Slack-Notion scenario

Hello guys!

I’m trying to make an automation where slack messages in a private channel are redirected to a Notion database and fill the properties of a table.

For this purpose, I’m using the Scenario SLACK (Watch private channel messages) - NOTION (Create database Item).

Nevertheless, when I insert the Database ID of my Notion Database, the error of “Database not found” appears. When I click “Select from the list”, my database does not appear in the list.

I’ve checked and I have my database public, with the connection to Make on, everything seems to be good. I’ve tried different databases and only one appears to work.

Database that works in the scenario:

Database that doesn’t work in the scenario:

Could you help me understand what is the difference between these two databases and why the 1st one is recognized in Make and the 2nd isn’t? I even tried to duplicate the one that works and the copy doesn’t work!

Thank you in advance!

Welcome to the Make community!

Your notion databases are not accessible to the public.

A common issue with that database not appearing in the dropdown is that you have to grant Make access for each individual database.

Could you also provide some information about your scenario?

1. Screenshots of module fields and filters

Please share screenshots of relevant module fields and filters in question? It would really help other community members to see what you’re looking at.

You can upload images here using the Upload icon in the text editor:

2. Scenario blueprint

Please export the scenario blueprint file to allow others to view the mappings and settings. At the bottom of the scenario editor, you can click on the three dots to find the Export Blueprint menu item.

(Note: Exporting your scenario will not include private information or keys to your connections)

Uploading it here will look like this:

blueprint.json (12.3 KB)

3. And most importantly, Input/Output bundles

Please provide the input and output bundles of the modules by running the scenario (or get from the scenario History tab), then click the white speech bubble on the top-right of each module and select “Download input/output bundles”.


Save each bundle contents in your text editor as a bundle.txt file, and upload it here into this discussion thread.

Uploading them here will look like this:

module-1-input-bundle.txt (12.3 KB)
module-1-output-bundle.txt (12.3 KB)


If you are unable to upload files on this forum, alternatively you can paste the formatted bundles in this manner:

  • Either add three backticks ``` before and after the code, like this:

    input/output bundle content goes here

  • Or use the format code button in the editor:

Providing the input/output bundles will allow others to replicate what is going on in the scenario even if they do not use the external service.

Following these steps will allow others to assist you here. Thanks!

1 Like

Hello Samliew! Thank you very much for the help.

I thought I had done everything correctly to make de databases public, on the three dots and “Connections”, and connect it with make…

The weird thing is that I didn’t do anything on the 1st database that I copied the link to, and that one works… could you help me to understand how to make the databases accessible to the public and to appear in the dropdown? Thanks!

More info about the scenario:

blueprint.json (4.9 KB)

bundle.json (14 Bytes)
inputbundle.txt (101 Bytes)

I think your issue is similar to the following:

1 Like

I read those two topics before and tried everything they said but couldn’t find how to do it…

I just wanted to know what is the difference between those two databases and why one works and appears in the list and the other doesn’t, so I can match them up! :slight_smile: