Notion database ID is not visible

Hello everyone,

I am trying to connect Make to my Notion account but the database ID is not visible in my make module.

I followed all the steps of another topic (database id not found) but my problem isn’t solved.

  • I created an connexion in my notion account, giving all the access
  • I connected my make module to notion with the API key
  • I went back to Notion to give access to my specific pages (which doesn’t have any parent page)

And i get the error message : Could not find database with ID

Thanks in advance for your help !

1 Like


Did you input the database ID manually, or mapped from some other module?

If you use the “Search” option in the “Database ID” section of your Notion module in Make > and then type the database name - does Make find the database?


Hi there, I have the same issue.
I followed all the step mentionned in the guide.
I’m pretty sure the issue comes from the connexion from notion

Same here, “Error, no matches found” even though I put the right Database ID ans my connexion between notion and make is valid

Is it possible to have someone from Make to book a call or something ?

Hi, for reference, here is the official Make guide to connecting Notion and Make:

If after following all those steps your connection still doesn’t work, let’s see if we could resolve this directly here, or whether it is a bug/there is something inherently wrong with the Make module/Notion API.

In such a case, could you provide screenshots/text of:

  1. The database ID you are inputting in the Make module
  2. Which Make module you are using
  3. The “Connections” menu in the Notion database you are using