Patch request fails from make.comn but sucessfull from Postman


When I make this request to an API (via Postman), I get 200 and a reply back. It is just a test system so “public access” is ok at the moment

curl --location --request PATCH ‘https://SERVER/public/exams/updateExamStatus/00af38b1-8b62-4e23-ae93-73368428ceda
–header ‘Content-Type: application/json’
–data-raw ‘{
“status”: false

When I try to send the request via it fails.
Anything wrong with the header settings?
Anything wrong with the content? I also Tried
• “status”: true
• status: true
• { status: true}
but same result
Any hint why?

Thanks rob

“ca”: null,
“qs”: ,
“url”: “https://SERVER/public/exams/updateExamStatus/00af38b1-8b62-4e23-ae93-73368428ceda”,
“data”: “{ "status": true}”,
“gzip”: true,
“method”: “patch”,
“headers”: [
“name”: “Content-Type”,
“value”: “application/json”
“timeout”: null,
“useMtls”: false,
“authPass”: null,
“authUser”: null,
“bodyType”: “raw”,
“contentType”: “application/json”,
“serializeUrl”: true,
“shareCookies”: false,
“parseResponse”: false,
“followRedirect”: true,
“useQuerystring”: false,
“followAllRedirects”: false,
“rejectUnauthorized”: true

“statusCode”: 400,
“headers”: [
“name”: “server”,
“value”: “nginx”
“name”: “date”,
“value”: “Sun, 08 Jan 2023 09:40:33 GMT”
“name”: “content-type”,
“value”: “application/json; charset=utf-8”
“name”: “transfer-encoding”,
“value”: “chunked”
“name”: “connection”,
“value”: “close”
“name”: “x-request-id”,
“value”: “ff04d0fc-e137-4291-b218-5174c1a9d405”
“cookieHeaders”: ,
“data”: “{"name":"MoleculerError","message":"Unexpected token in JSON at position 1","code":400,"type":"entity.parse.failed"}”,
“fileSize”: 119

Answer from POSTMAN where request is succesfull

Hi @ICO,

could you try and remove all whitespace in the JSON-Body?
I would try {“status”:true}. I feel like sometimes copying a body over from one program to another it creates some weird spaces, tabs… that the other system isn’t able to handle. Not sure if that’s the error, but I’d give it a quick try :smiley:

1 Like

Joop - normally I’m very carefull with copy and paste , but this time (from psotman) not … cost me an hours but … Thank you …

I feel your pain :smiley:
Whitespace is the worst error xD

whitespace “by hand” also works - it was the copy from Postman to … AHHH

Can you do me a favor and see how many cookies postman returns vs Make? As I am having problems with make only returning a single cookie vs four cookies?

I think for me it was the same :confused: