Problem scheduling video posts on TikTok via Buffer with Make.com automation

Hello, community!

I’m encountering an issue while trying to automate TikTok posts using Make.com in conjunction with Buffer, but I’m running into a specific problem related to including videos in the posts. Every attempt to post results in the following error message from Buffer:

400: Tiktok is all about the videos! Up for adding one to your post and trying again?

Automation Setup:

  • I am attempting to create a post that includes a video.
  • I use a direct link to the video hosted on Airtable (MP4 format, publicly accessible).
  • The “Attach media to the update” field is set to true.
  • The “Title”, “Description”, and “Thumbnail” fields are left empty, which I assumed to be acceptable since the focus is on the video.
  • The “Shorten links within text” option is enabled, but “Attach links in the text as media” is disabled.
  • I am attempting to post immediately (“Publication: now”).

Issue:

  • It appears that the system is not recognizing the provided link as a video, or there is some configuration I’m missing that is essential for successfully posting on TikTok via Buffer.

What I’ve Tried:

  • Checking the video link to ensure it is direct and accessible.
  • Testing with different video formats (MP4 and MOV).
  • Reviewing Make.com and Buffer documentation for any specific configuration that might have been overlooked.

I am seeking help to understand what might be wrong with my setup or if there’s an additional, undocumented step I need to follow to successfully integrate TikTok with Buffer via Make.com. Any insights, suggestions, or guidance would be greatly appreciated!

Thank you in advance for the help!

3 Likes

Hi,

did you manage to find a solution?

I am having similar issue with TikTok, Instagram and YouTube upload through Buffer.

Sadly, uploading directly through TikTok API Call doesn’t work since according to their docs they changed base url address for their api- module in make has outdated base url.
When it comes to YouTube upload - it’s non-existent.

I managed to setup Buffer on Zapier, but it’s quite costly and I would like to make the workflow run here on Make.

Hi,
I am encountering the same issue. I provided the link of the mp4 video created by Creatomate and it is not working. The video link is accessible though. Does anyone know what we are missing here ?

Thank you in advance for the help!

Same Issue. Whether Buffer in Make can not upload a video? I can’t find any description in Make

Buffer has deprecated their API and no longer supports it. Therefore I do not recommend using the Buffer integration as it may break any time.

According to this article, you can use a similar product called Ayrshare, however this external service doesn’t have an integration on Make yet.

Ayrshare has a Developer API Reference/Documentation, which you should be able to integrate the endpoints in Make using the generic HTTP module.

You can also suggest for it to be made in the Idea exchange. Don’t forget to search for it first, just in case someone already suggested it, so that you don’t end up creating a duplicate.
Screenshot_2024-01-17_130153

You can get a Ayrshare API key here https://app.ayrshare.com/api for use with the HTTP “Make an API key request” module.

If you need assistance in setting up the generic HTTP module to call this external service, please start a new thread, providing information about what you have tried with regards to the external service’s Developer API Reference – how you are setting the connection up, a link to the endpoint are you trying to connect to, and what errors you are encountering.

2 Likes