Solving error:'This execution cannot be displayed: blueprint version is missing'?

hey folks :wave:

First time I’ve run into this error, and going by the existing posts in the forum there has been no clear solution and/or assistance given from the Make team to solve it.

Still, thought it’d be worth a shot — has anyone else faced this error and found a way to solve it?

I’ve tried rolling back the scenario to previous version(s), then making the necessary changes to my scenario, as well as exporting and importing the blueprint into a new scenario — all with the same resulting error. :confused:

@sestere or @kevinleesmith — did you arrive at a solution for this?

TIA! :v:

Heya @aidy hope you’re well :wave:

So I got this guide from the team that I’ve just posted in here as well:
"This execution cannot be displayed: blueprint version is missing"

Currently, pre-validation errors in Make are unable to display the logs in a modal, which can result in the default error message of “invalid blueprint”. To address this issue, we can use the network tab to navigate to the actual error and fix it.

The network tab is available in all types of browsers. To begin, open your browser’s Network Console and make sure to keep it open for the following steps to record the network activities.

Next, access the specific scenario history page where the error occurred or run the execution where the “invalid blueprint” error was displayed. Copy the execution ID from the URL bar or from the logs and paste it into the search area in the browser Network Console.

You can then open the scenario log from the Network tab and review the pretty JSON format to identify the error. The log should display the error from Suberrors, and we have included a GIF to assist you in locating it.


I really hope that this will help resolve the issue.

Feel free to let us know whether it worked for you.

1 Like

Great, thanks @Michaela!

I’ll try this method out next time I face this error :ok_hand:

This time around I solved it by building a new scenario from scratch — wasn’t confident that I’d get a solution to fix the existing scenario, as there was no resolution in those old related posts.

(New scenario because import/export, as well as cloning modules from the original scenario with the error to a new one also caused the same error)

Appreciate the help! :blush:

1 Like

fwiw i did get this error during the “error free migration process”.

I dont recall any response from make when i reported that error (as it took them weeks to respond to my problems (during the “error free migration process”)

I think it just went away over time.

1 Like

this does not help, can you show us in a video maybe?

Hey @Lloyd_Johnson ,

Nope. I’m not going to record a video of me rebuilding my client’s scenario from scratch to get around this issue. :sweat_smile:

@Michaela posted a method for identifying the specific error(s) that can cause this ‘blueprint version is missing’ case.

I recommend you follow those steps before deciding if rebuilding the scenario from scratch is needed (I only went with that option as there wasn’t any info in debugging/fixing this prior to Michaela’s update)

1 Like