Unable to see my Facebook Pages in Make

Hi, I am trying to create a scenario that I’ll be able to use to create posts accross multiple Social Media platforms like Facebook, Instagram, Pinterest etc, from a single place.

The issue:

I’m trying to upload a picture post to my Facebook Page using the [Facebook Pages > Upload a Photo] module, but the pages linked to my Facebook account are not showing up in the Page field event even though the page shows up when I login to my Facebook account(that is, the OAuth flow) to create a connection and all permissions are given to Make.com during the OAuth flow. And this issue is specific to my client’s account.

When I use my personal account everything seems to work fine. All my pages show up, and I’m able to select them and Create Posts in them using the [Facebook Pages > Upload a Photo] module.

I’m approaching my deadline for the completion of this setup so its stressful.

Any help on solving this will be greatly appreciated.
Thanks in Advance.

Hello there,

I’m not entirely certain if this issue is related to Make.com. It seems more likely that the problem is coming from the side of the account you’re trying to access.

Here are some troubleshooting steps that may help:

Firstly, review your user role. Make sure you have the necessary Admin or Editor role on the Facebook Pages you’re working with. Without these roles, you won’t be able to perform the desired actions.

Secondly, check for any restrictions on your client’s page. Verify the page visibility settings to ensure you have the necessary access.

Thirdly, review all app permissions and re-authenticate your connection. This may help to resolve any issues with the connection.

Lastly, you can try refreshing your form to see if that helps.

I hope this helps to resolve the issue. Let me know if you have any further questions or concerns.


1 Like

I’m pretty sure my account has all the necessary permissions, in Facebook Business Manager I can see that my Facebook acccount has full control over the page.

And secondly, I tried posting a photo using the page id instead of selecting the page from the dropdown field in the Upload a Photo module, and it worked so the required permisions should be there.

But it does’nt matter, since all the pages magically appeared today(the question was posted a day ago) without changing anything on Facebook Business Manager, so my guess is it definitely is a Make problem.