Make dropdown doesn't show some Facebook Pages

Problem to connect Facebook Page using a module. (Some) pages do not show up.

  • Goal: connect Facebook page using Make’s Facebook Pages module
  • Steps taken:
    • used standard Facebook Pages module → add connection → all pages chosen → all privileges granted
    • result: only one page shows up (should be all 3)
    • followed instructions from docs:
    • in FB business integrations rechecked: make app exists, all privileges granted, saved
    • removed the app reconnected again with the same result
    • created new FB connections in make with the same result
    • in Make connections tab, reauthorized and verified connections with the same results

Additional details:

  • I have full access and control over the pages
  • everything worked until circa the first week of September (the dropdown showed more than one page), when I made a new scenario and reconnected the integration
  • pages not showing are relatively new, created this year (I created fresh one just for test)
  • at the moment the only available page in the dropdown was created some years ago
  • as far as I noticed there were some changes in Facebook Meta Business and how pages and assets are managed (business asset groups)
  • for my FB account I use two-factor authentication (for years now, the integration worked before)

Any thoughts?

According to Facebook API me/accounts returns not all pages - Stack Overflow,

Some types of pages require additional permissions. These permissions need to be selected when generating an API token:

pages_show_list , business_management , pages_read_engagement , pages_manage_metadata , pages_read_user_content , pages_manage_ads , pages_manage_posts , pages_manage_engagement

You may also need to go here, and click on the Make Integration, then check all the pages have been selected:


Hi Innova,

we had a similar issue with an Instagram page not showing. It was an authorization issue and I suppose you are having the same one. Go to this link:

And click View my accounts → from there see if the account is restricted and how to resolve it (usually by adding a 2FA app on your phone).


Thank you for your input @Stoyan_Vatov .

In my case there are no visible issues. All the messages there shows “No account or asset issues”, “No Advertising Issues”. But yes, it’s clearly a place worth to check, that I did not.

I have 2FA turned on for years. My Make-FB integration worked before with no additional settings.

It can be the case with permissions indeed.

Although I have full access and control over the pages and all privileges are granted in the Make integration:

I have no control on how the Make integration app works, so I can select only available radio buttons. All are set to on. It seems it should be enough. There is an option ‘Show a list of the Pages you manage’. These settings can also be set when making a new or reauthorizing connections in Make. I did it, but to no avail.

It worked before perfectly until some changes on Facebook side, when they changed how business assets are managed (July/September 2023). It could be connected to that. However it seems that if there was a bigger connection issue for everyone, more tickets or topic here in the community would mentioned that, and the problem would be resolved by now by Make tech team. So I don’t know.

1 Like

We’re having the same exact issue here where we connected our Facebook and make sure all the permissions are correct and re-authorized and reverified but we still don’t see the Facebook page showing in the drop-down menu

Unfortunately I did not find any solutions and the Make help desk staff wasn’t helpful, except them being, fast, nice and sending standard docs, which I already included in my question.

For now I can only add that it’s clearly problem with Make platform. I tested connection on Zapier and created a new similar scenario that worked. It can’t be a problem with Facebook permissions, otherwise it wouldn’t work either.

It looks like some kind of OPcache on Make platform, but then it would work after making a new connection. I don’t know. I deleted connection and reconnected many times without resolving the issue, both on my existing scenario and by creating a new one.

What’s more interesting I created a new Make account, and I was approached by the same problem. However, my guess is that if more people had similar issue, Make already would have found a solution, because people would overrun them with bug reports after Facebook changed how permissions, business accounts and assets work.

Hello @Innova thank you very much for bringing this up here in the community :pray:

I just wanted to step in with a quick update. This issue is currently being investigated by our dev team. So far, it has not been confirmed whether this is an issue on our end or not.

It is possible that this is caused by Facebook access permissions. Currently, it seems that the pages don’t load when also connected to an organization inside of Facebook Business Suite for ads. When the page is removed from the ad account, it seems to start showing up.

I will make sure to monitor this issue and will post an update here as soon as I learn anything new. If you’d prefer to receive updates directly in your inbox, you can open a ticket with us and our support team will automatically notify you once there’s any news to share regarding this matter.

I genuinely apologize for any frustration or inconvenience this situation may have caused you. Thank you very much for your understanding and for bearing with us :pray:

A quick note: We removed your last comment from your previous reply as it was against the Community Guidelines which prohibit recommending or promoting competitor solutions here. This is to ensure the community’s integrity remains intact. Thanks for understanding.

1 Like

I just encountered the same issue. I went through all the troubleshooting guides I could find, but everything looks as it should in my settings.

I then tried to just enter my Facebook page ID instead of using the dropdown and that worked.

1 Like

Thank you. Using FB page ID is a good tip. I did before though. It hasn’t helped in my case.

Currently, it seems that the pages don’t load when also connected to an organization inside of Facebook Business Suite for ads. When the page is removed from the ad account, it seems to start showing up.

I haven’t linked it to any ad account yet. In addition, I experimented with a brand new page, which also had no ad account. Later I added both pages into two separate Business Assets Groups, but it wasn’t functioning prior to these changes.

Same issue, but I do confirm that entering the page id directly works. The fix:

I am creating a variable so I don’t embed this ID into my scenarios.

Thank you, I can confirm, that it worked for me.

I tried this method before, but I made a mistake and did use the wrong ID. Apparently I copied ID from my page url, but this is not the correct page ID. I checked again this method and it returned 100 authorization error in Make. I investigated and found out that I had had copied wrong page ID in my notes.