Why was my Google Workspace connection dropped mid-scenario execution?

Why would a connection drop midway through a scenario’s completion?

I was able to reconnect and resolve the incomplete execution, but I’d prefer the scenario just kept working correctly of course.

Context: using Google Workspace modules connected via a Workspace Admin account to onboard users and provision them with workspace accounts and such.

Specifically, in the scenario I first use the Gogle Workspace “List Users” module, then the “Create a User” module. I then have a sleep delay (to give Google time to update relative to the newly created account). When the execution got to the “Update a User” module, the scenario borked:

This happened first with a scenario starting at 7:16:35a and then by another one starting at 7:18:34a

Incomplete Executions were created at 7:21:39a & 7:23:38a respectively (just after a 5 minute sleep module)

1. Should I expect that connections to Make will just randomly drop?
2. Is this just smething google does every so often?
3. Was this the result of rate limits?
4. Should process this scenario sequentially?
5. I didn’t receive any notice in the connected account’s email or admin alerrt notices (I did get the scenarrio warnings, to be expected, but they don’t address why the connection stopped being authorized, just that it was :man_shrugging:) - how can I even begin to truobleshoot this on the Google side?
6. Would increasing the delay have prevented this? Currently it is 300 seconds (5 min)
7. Why did the first two modules run fine, but updating the user didn’t?
8. What can I do so this doesn’t happen again - should I regularly reauthorize all my connections?


Screenshot 2024-01-12 at 11.25.41 AM

Anyone have any ideas? Thanks!

Did you check with your google Admin if they setup some API / OAuth timeout? Set session length for Google services - Google Workspace Admin Help


@Wemakefuture thanks for the suggestion. The Web session duration is set to 7 days. The scenario has been running for years without throwing this error, so I am guessing that is not the culprit.

Ah, so your connection times off every 7 days, here is the reason why: gmail - Google oAuth refresh_token expires after 7 days, but for one account only - Stack Overflow


Welcome to the Make community!

You might need to set your Google OAuth application to “Production”, otherwise the credentials expire very frequently.

1. To do this, go to menu item “OAuth consent screen”

or click here https://console.cloud.google.com/apis/credentials/consent

2. Then click the button below if the Publishing status is not “In production”


@samliew , as I replied to @Wemakefuture - this scenario has been running for years without this problem of dropping the connection mid-scenario.

Of note as well, an authorized connectioon was successfully used in a GWkspace module (“List Users”) was used in the step prior to the failed GWkspace module (“Create a User”), and it ran just fine.

Thanks for the suggestions, but I am not going to change the organization settings per your suggestions as they do not apply to my situation.

@Wemakefuture , again - if that were the case, then I would have seen this prior. Thanks anyways.

Hey @mixelpix , sometimes things change…specially with big cooperations focussing a lot on security like Google.
Have you seen some of the advises on this topic? Google Authentication issue: Status Code Error 400 - #14 by Pedro_Marzagao


Thanks @Bjorn.drivn - do things in Google tech ever not change :wink:

I’ll check out the link, thanks!