Ack JSON Parser! Missing value of required parameter 'json'

I figure I’m missing a simple JSON thing that I’m not seeing. It works when I manually cut&paste the JSON into the parser but not when the scenario runs.

Error when running scenario: :point_down: :upside_down_face:

But when the JSON parser module is run manually (cut&paste JSON file from webhook queue), it works. :point_down:
Screenshot 2023-04-06 125922

Manual testing success: :point_down: :partying_face:
Screenshot 2023-04-06 130119

In the JSON Parser, there isn’t a Data Structure used. :woman_juggling: In the manual approach, it wasn’t needed.

What could be missing here? Is there a step before the parser?


Can you show the input bundle into the JSON parser when it runs automatically with a webhook? Just use the little output/input bundle icon when looking at the Operation 1. I see Data size is set to 0 and I wonder if your input bundle from the webhook is simply empty.

1 Like

Dang, good call. The input bundle is empty on the JSON parser. And yet the output bundle for the webhook has the JSON file.

Screenshot 2023-04-06 132327

I’m not sure what this actually means when this happens between these two modules.

Take & share screen shots of the output bundle from the webhook and the webhook config and also screen shots of the JSON Parser configuration before running the scenario.

1 Like

Thanks for being helpful Alex. :slightly_smiling_face:

Here’s the webhook config: :point_down:

The webhook output bundle:
Screenshot 2023-04-06 132327

And then the JSON parser config: :point_down:
Screenshot 2023-04-06 132814

Does this help?

I did notice something. In the email, there was a “+” in the webhook output bundle but not in the JSON string of the JSON parser. Either it was stripped out or the UI isn’t showing it.

Screenshot 2023-04-06 143806

That seems strange that the parser would strip this out as it’s a string within quotation marks.

I’ll give this another test with an email without a “+”.

UPDATE: the test with a different email had the same error. :cry:

Hi @Tom_Hudock,

Few questions, why do you need to parse the JSON as the data that you are getting is already preformatted? The webhook config as you have shown have a JSON pass-through disabled, which means that the data that you are getting is already preformatted in Webhook.

If you need the JSON string, disable the JSON pass-through and run the Parse JSON module again and see if that fixes the issue you are getting.

1 Like

You’re right, @Runcorn ! The JSON parser was unnecessary and the webhook provided the fields when the JSON pass-through was disabled. Thank you for helping with this!! :partying_face:

This solution also fixed the problem receiving an email with a “+”. The webhook didn’t mess with it, like the JSON parser did.