Cannot push messages through Manychat

Not sure if I am doing something wrong or if the module has a problem but I am simply trying to push an output through a message in Manychat but I keep getting a weird error.
It is saying it can’t create that message type with RPC Buttons…like I have set up the message in the wrong section (which I have not).
Here’s the scenario, settings, and error:

Make support sent me to Manychat support, so I’m currently in the dreaded support loop. Any help appreciated.

Hi. You are sending a property “type” that do not exist in Manychat. Review your data model and API docs.

If you need additional support, please don’t hesitate to reach out.


Yes. I need additional help because this doesn’t make sense to me. The type is TEXT, also, all settings are in-built options in the module, so I didn’t add anything new.

Well, I think you really need the Manychat support for this case. The module you are using is trying create a type not send an existent type. So only they can help you to debug this:

If you need additional support, please don’t hesitate to reach out.


@Signalytics Instead of the variable you are trying to add, try to put some static (hardcoded) text in there instead. If this solves the issue, the data type your trying to send is incorrect.
If this doesn’t solve the issue, it might be a Manychat module bug (but unlikely)

1 Like

Hi, I am experiencing the same error. My previous flows recently migrated from Integromat to Make are working.

But new flows created in Make throws this error. Is this a problem isolated in Make? The only difference between my legacy flow and the new one is:

  • Works: Make >> Manychat >> Messenger
  • Failed with error: Make >> Manychat >> Telegram.

At the moment, I’m only able to direct the flow back to Manychat but I can’t use the Send Messages module due to same error described in this post.

Did anyone find a solution or workaround?