Filter not working in Todoist Notion integration

Hi there,

I have an integration between Todoist and Notion for my to do’s. If a to do comes up I can add it either on my smartphone via Todoist or on my laptop through Notion. What I basically want is a sync between the 2 systems.

I have 2 scenarios, one that adds new to do’s from Todoist in my Notion database and one that adds new to do’s from Notion to Todoist. The issue I’m running into is that this triggers an infinite loop. The 2 systems start automatically adding the same to do’s in each others database.

Therefore I have added a column in my Notion database called Added by Todoist which is either true or false and I use this as a filter when sending new to do’s from Todoist to Notion. This is working fine.

However, I need to do the same in the other direction. I have created a label in Todoist called “Added by Notion”, but that isn’t working.

I want to use this label as a filter saying “if this Added by Notion label is NOT checked, only then continue and add the to do”. This should fix the problem in both directions, but I’m not sure how to set it up.

I see in Todoist that a label is being added by Notion, but it doesn’t say Added by Notion, but rather some sort if ID:

When selecting the label as a filter in Make, I can choose between 2 labels, which is Added by Notion and the ID. Very strange.

Here are some screenshots of Todoist and my Make scenario.

Hope you guys can help.

Are you sure the labels that you added are boolean values? Another question I have is perhaps this filter looking for whether any sort of label exists and not whether or not the specific “Added by Notion” is true or not.

1 Like

Thanks a lot for looking into my question Anthony! I’m not sure, they are just labels, so there might not be an actual value besides set or not set, I’m not sure.

If the filter was looking whether any label exists, that would also work for me, because if so, the to do shouldn’t be sent to Notion and that would solve my issue, but currently it doesn’t. So going that route, I just changed the settings of the filter (Loom | Free Screen & Video Recording Software | Loom) but it’s not working either.

I don’t understand a lot about how to use the fields that Make gives you. So I’m assuming I’m doing something wrong with the filter condition and assume that the “{{1.labels}}” isn’t correct. I probably need to enter something withing the breaks, but don’t understand that. I actually thought that a tool like Make would make this part easier and no code :man_shrugging:

I don’t think you are doing something wrong. I saw your Loom and it looks like you’re selecting the label correctly. I am wondering if you have gotten more test data recently or are you working with older data and it may not have reflected the change you have made in Notion. Try running the automation again or just the Notion module and see if you get new output data?