Find Salesforce Record Id based on other unique identifier

Hi Everyone,

I am newer to Make and not seeing a easy solution for this in the help docs or community. We have a custom object in Salesforce that stores the tasks from our project management tool (clickup). When a clickup task is updated, I want to update that matching record in SF. In SF we store the unique ClickUp Id on a field, but I am not sure how I do that mapping, it only lets me search by the SF 18 digit Record ID when doing UPDATE RECORD or GET RECORD. I tried SERACH RECORDS and could get a SOQL search to find it, but not sure how I can get that result into the UPDATE RECORD id field.

Has anyone had luck finding the SF ID using a different field then storing that value in some sort of variable?


@Rob_Cardenas :raised_hands:

Hi there! Thanks for reaching out to us. We understand that you are looking for a way to update a record in Salesforce using a custom object. We are here to help and we would like to get more information from you in order to provide the best solution. Could you please provide us with more details about the custom object and the field you are trying to update? We look forward to hearing from you and helping you out. In the meantime, stay tuned for our community members to answer your question.

Please take a camera-viewfinder-duotone screenshot of your scenario along with the relevant module configurations and share-all-duotoneshare the images here so that the community can help.

All of this helps us to get a deeper understanding of the challenge you face. :make:

In the update a record. You just need to select the type of record. from the list.
Map the fields you want
and put in the record Id from your search soql you said to get the id. The id should be in the output if your query is set correctly to return id. If that does not work show the screenshots please.

1 Like

Thanks for replying Jonx! Here is the screen shot of the query (If I run in data loader I get a result), then what our options are on the next steps after the metadata refreshes. Thanks!

Can you put the actual id in sosl query and remove the taskid mapping
Lets make sure the query comes back with a result first thing.

1 Like

I removed it and up the actual ID and got no results. Here is what I get in dataloader. I am using the same user account to connect and its an admin. Thanks for your help.

Use the SF make api call
Set the parameters exactly shown in the screenshot
Then in the value field put in your query.
See if it returns id

That worked! Thank you!

1 Like