Fortnox unsupported scope


Trying to use the Fortnox integration. I have created an application in the Fortnox developer portal and enabled the following scopes:

  • Customer
  • Order
  • Invoice
  • Supplier
  • Supplier invoice

In Make I have created a Fortnox node in a scenario, configured the client ID and secret, and selected only the Invoice scope, but when I click save, the OAuth dialog gives me the following error:

  "message": "The request failed due to failure of a previous request.",
  "code": "SC424",
  "suberrors": [
      "message": "[invalid_scope] An unsupported scope was requested",
      "name": "InvalidConfigurationError"

I have the same problem.

I have kinda figured it out. It appears that Make is requesting a number of predetermined scopes in addition to the ones you explicitly select in your Make connection. So your Fortnox application requires more permissions.

If you open the developer console in the OAuth window as soon as it pops up you may examine the requested scopes in the request that’s sent to

1 Like

Hey there @et.fz :wave:,

Just thought I might step in and pat you on the back for the great job you did while figuring out this problem. I’m thrilled to see you were able to learn more about the product and come up with a solution! :clap:
Also thank you for coming back and sharing this.

Keep up the amazing work!

1 Like

I can see the scopes, but I’m not sure how to bypass the error…

You need to enable in your Fortnox application all the scopes listed in the request.

1 Like

Sweet! Got it working now! Thanks!