Instagram reels Error: Media upload has failed with error code 2207026

I’ve been trying to automate instagram reels upload process.
At first tried with google drive, than moved to gcs, than realized maybe there’s a problem with my instagram connection.

So I isolated the connection to literally only instagram reels, created a public, naive, 3 seconds short video file on gcs, configured a whole new scenario to upload a reel from that URL, and it still doesn’t work.

The file can be found here:

Adding a screenshot, notice the error code, literally any help will be highly appreciated

Welcome to the Make community!

Here are similar issues that other forum members have encountered before:

The video format is not supported (error code “352”, subcode “2207026”) Here, the Instagram publishing error is because the format of the video must be MOV or MP4 (MPEG-4 Part 14) file. We therefore invite you to import your video in one of these formats and try again to publish your video.


Look at the file in the added link, it’s .mov

How are you mapping the URL into the instagram module?

1. Screenshots of module fields

Please share screenshots of relevant module fields in question? It would really help other community members to see what you’re looking at.

You can upload images here using the Upload icon in the text editor:

Following these steps will allow others to assist you here. Thanks!


I am having a similar issue as well. using MP4 video files stored on Airtable as an attachment.

Here is the input bundle going into the upload reel module:

        "caption": "📱 Posting on the go has never been easier with GMG's ContentDB software! Just ask Alex Green, CEO & Founder of GMG. Try it out for yourself! 💬🚀\n#startup\n",
        "accountId": "1784146229982XXXX",
        "video_url": "",
        "share_to_feed": true

And this is the output bundle that comes out of the upload a reel module:

        "status_code": "ERROR",
        "status": "Error: Media upload has failed with error code 2207026",
        "id": "1784753033116XXXX"

Here is the details of the video that is available through the airtable attachment link:
Screenshot 2024-03-31 152340

I tried with multiple videos that I had filmed from my phone and it gives me the same error message.

Any help would be much appreciated.