Trying to connect to Instagram for business and getting this error (#10) Application does not have permission for this action

When asking your question, please include:

Trying to connect to Instagram for business and getting this error

DataError

(#10) Application does not have permission for this action (10, OAuthException)

Origin

Instagram for Business

2 Likes

I am also receiving this error here is a screenshot for attention

1 Like

Try to reconnect the module. Maybe that will work.

1 Like

1st thing i tried but still same error.

Can you show the entire module. and Any error code you can see?

1 Like

Have you find the solution @Lloyd_Johnson ?

i did not. i also did not reply to Kinge up there because my OP had what he was already asking.

hey did you get this to work? Also having the same issue

Hello. Anyone being able to solve the issue?
I’m getting this problem not being able to get Instagram data.

The operation failed with an error. (#10) Application does not have permission for this action (10, OAuthException)

Can someone help?

Same here – just cannot seem to get it to connect and can’t see why not.

Hello everyone @here and a warm welcome to the community to the newcomers :wave:

I just wanted to step in with some info that I thought might be helpful.

Given that this appears to be a connection issue, it’s important to remember that Instagram Business accounts connected to a Page that requires Page Publishing Authorization (PPA) cannot be published to until the PPA has been completed.

1 Like

Hi Michaela – I was drafting a reply yesterday that I finally got this to work, and I did. What I did differently was I adjusted the LIMIT to 1, it was previously 6 in my test. And then, it worked. However, I got an error with my post-comment module. But each time after the connection module was working, it never failed again during my test. Until it did again (read on)

I didn’t change anything in my authorizations (my pages already have access to post as I use publer.io today for my posting automation and that works perfectly fine)

HOWEVER, when I was having the issue posting my comment. Assuming I had the connection module issue figured out, I deleted my connection module, partly because I wanted to confirm if I could reproduce the steps to get it to work again, and two, because I wanted to create a clean scenario to see if I could fix my posting comment error.

When I deleted and recreated my connection module (in the same scenario where it was working), the new connection module stopped working and gave the same error as before.

So I don’t know what caused it to start working, but it hasn’t started working again regardless of what I’ve tried.

odd!

Heya @t4cki3 :wave:

Thank you so much for keeping us updated on your progress :pray:

Your troubleshooting steps make sense, and it’s unfortunate that you haven’t been able to pinpoint the root cause. If you could share more details regarding the setup or any error messages, it might help the community offer some insights.

That said, it’s also possible that this issue is account-specific and requires deeper investigation. For that reason, it might also be a good idea to reach out to our support team. They’ve got all the right tools and know-how to get to the bottom of things and help you find a solution.

1 Like

It’s working again now, very consistently. No rhyme or reason as to why though as I haven’t changed anything.

But now the posting comment in IG doesn’t work so I’m off the try and solve for that.

I have same issue for a couple of months. PPA just redirects me to Facebook Ads Manager out of context. I’m clueless on this as both supports seem to give vague answer on this or no answers at all. Worst thing is that everything was working fine which gave me hope and now it just stopped

update: now instagram module is not showing my pages at all… it just going backward when everything was working fine

1 Like

Instagram Reel Module is not showing my instagram account. Please can advcise?
Biscuit_i6hkC48jfm

I dont know why would it redirect me to Facebook Ads Manager pay but when I try to login it just loops asking my for password.

How to escape this madness anad use Make Instagram Reel Module?

1 Like

Has anyone gotten this to work? I’m getting this error as well

1 Like

anyone able to make it work?? @Michaela

1 Like

Same problem here too! It’s January/24 and this haven’t been solved yet.

Hello @noName @mauriciomdea welcome to the community :wave:

I just want to let you know that there are currently no reported issues related to our Instagram Business modules. As I mentioned above, this is very likely a connection issue. :arrow_down:

If this information does not help, I would recommend opening a support ticket with us. Our support team has the right tools to investigate this more thoroughly and provide any necessary further guidance.

Thank you :pray:

1 Like