Weird Make Issue

Hi Make, a weird issue has just emerged. Getting some weird errors however the scenario is still running.

Kindly advise

Make Eror

Hi @Keep_Innovations ,
Can you send a screenshot with your scenario please?

Hi Wemake future

Find it below, however please note the scenario keep running, records updating but keeps sending me scenario failure notifications

  1. Break stores the input to the queue of Incomplete Executions(If a module encounters an error during its operation (see the Errors resulting in incomplete executions), a new incomplete execution is added to the Incomplete executions folder. Each incomplete execution contains the scenarios blueprint and all the bundles that can be mapped into the failed module) and the scenario execution status is marked as a warning.

  2. Clicking the gear icon in the scenario editor will open the Scenario settings panel. Here you can set various advanced settings.
    The Sequential Processing setting determines how Make processes recurring incomplete scenario executions. The Incomplete executions folder must contain scenario data.

  • If enabled, Make stops executing the scenario until you resolve all incomplete executions. This option guarantees that Make will always solve incomplete executions in sequential order.
  • If disabled, the scenario continues to run according to its schedule, regardless of errors.

3.This is IMLError :

  • These errors occur when the function that is used for custom apps is not written correctly.

I hope it helped.

//VLAD

2 Likes

Break is fine, I can change the handler if required. The IML is my concern

@Keep_Innovations ,
Is this app developed by you? If YES then you need to check the “formatOutputAlt” function because it is clearly written wrong, otherwise you need to contact the developers of the application.

//VLAD

1 Like

On it, thanks for the feedback

2 Likes

If you have any further questions please do not hesitate. Thank you.

I see that you’re getting the error when integrating with Ninox. I have had things erroring out on me all morning, and all of the integrations are connected to Ninox as well. Ninox must have updated something on their end that’s broken things.

Same with me. 3 Ninox scenirios with

“IMLError

Function ‘formatOutputAlt’ finished with error! Cannot read property ‘find’ of undefined

Origin

Make”

@here Hi everyone and welcome to the community to the new joiners :wave:

I am just stepping in to say thank you for raising this here and to confirm that the issue with Ninox has been noted by the devs. The team is working on fixing this and, hopefully, all will be back to normal soon.

I understand that this is frustrating and I’m really sorry for the trouble this is causing. I’ll make sure to post an update here once I learn that the issue has been resolved.

Thanks for your understanding and for your patience :pray:

6 Likes

Hello Michaela, is there any idea when the problem might be fixed? We have a number of business critical scenarios that are affected by the error, including shipping and customer onboarding.

Yes, as Ninox have verified the issue is on the Make end. There needs to be a timeline

1 Like

I have multiple scenarios for me and clients down because of this. An update would be very helpful.

I agree an update is warranted, I am even thinking of reverting to http modules to keep things moving in Ninox…So that if we need to put backup plans in place, we start working on it as they fix things up.

@here Hi everyone!

I am looking into the system and see that this is being worked on with urgent priority. The devs have identified the source of the issue and the fix is waiting to be deployed into the live version. Unfortunately, I don’t have a specific ETA I could share with you but I am sure this will be resolved very soon.

As I said above, I will make sure to update you here as soon as I learn that this has been fixed.

Once again, so very sorry for all the inconvenience this is causing. We’re working on making it right, I promise. Thank you for bearing with us :pray:

I hope Ninox is solving the whole problem. There is a problem with every API right now, not only Make :frowning: Nothing works…

Hi Rashakiel, the problem is mostly in Make…Ninox and other services seem to be running minus an issue if you interact with the public APIs directly

since the new version 3.7.11 update yesterday nothing works anymore here. Nothing syncs anymore and even if I just press a button that is not tied to any API, an eternal loading bar comes up. I guess there are some more problems :smiley:

Edit: Every API works right now. I guess its solved.

@here

:loudspeaker: So I’ve been told that the fix was deployed ca 15 minutes ago. :loudspeaker:

All should, hopefully, be back to normal but feel free to update me here in case you’re still experiencing any issues.

Thank you so much for your patience and - once more - so sorry for all the trouble this has caused you.

1 Like