Setting up new 365 Email - Folder Failed to load data

I’m still struggling from the post that I made: All scenarios are failing with email login failed since the 22nd - #6 by Michaela

I’m trying to create a scenario from scratch as suggested and I’m stuck right away. I successfully add the OAuth email account and then when I go to select the folder is says “failed to load data”

Any suggestions?

This issue generally happens when the IMAP is disabled in your account. Hence, you need to enable IMAP on your Workspace settings.

Also, another reason is an issue with the existing connection. So you can remove the existing connection and create a new one from scratch as described in the documentation.

Refer here:

1 Like

Thank you for the reply. I did delete the connection and start from scratch as suggested. I do have IMAP enabled in my Org Settings and on the individual account. When I try to log on with IMAP I get login failed at the setup screen. Microsoft changed this recently pushing to use OAuth

When I add OAuth it allows me to do the setup but fails at authentication when I run the scenario.

After reviewing the document above I did not do the step 4 Obtain Client Credentials. I started to go through it but ran into a few bumps so I backed out. Do you think this is needed to get it to work?

1 Like

Just a bump on this to see if anyone has any suggestions.

Any other ideas? Support finally contacted me after 25 days and gave me the same link showing to setup OAuth.

I do have one of the 7 scenario’s that still work for some reason. However, there’s no account in the connections field. I can’t leave this blank when creating a new one. In the connections tab it shows that it’s connected via IMAP. I’ve tried recreating others with IMAP and it fails to login.

Same problem here! It wont load the folders and I cant proceed.

Same here! I just want to save attachments, but because Microsofts Api cannot handle signed mails I thought this Api would do the trick.
Very disappointing.


It connects but doesn’t load the folders!

Can’t believe there is no fix for months for this! And I started to build whole my 19 hours flows into this! Put a warning at least!!! @Michaela

Heya for the third time @onurbolaca, please see my comments below :arrow_down:

Hope this helps :slight_smile: